Strange typing behavior on Noteself app and Firefox

Hi, I have a strange behavior when typing anything into the main content of any tiddler. This occurs on my mobile android device only, in the noteself app and on Firefox but not on chrome.

When typing, the cursor gets put to different places, sometimes back to the beginning where the typed word was started, sometimes to the current position, sometimes anywhere else in already existing text.
Additionally, words around the curser are copied several times and put into the text as well. It is hard to describe, I provide a screen capture.

I have no clue what is happening our how to resolve this problem. Please help, as this renders noteself unusable on mobile for me :frowning:

Hello @steffenms
Thanks for the gif. I think the problem is because you are using the codemirror plugin. Can you try a version without the plugin and report back? For example, by navigating with your mobile firefox to
Then you can go to and confirm that the problem happens on that version because it also uses the codemirror plugin.

When you say the android app, do you mean the actual android app? Or using an android browser?

Hi @danielo515,

Thank you for your fast reply. I do not have this problem at
I disabled the codeMirror Plugin, but it did not help. I tried to disable every other Plugin, that might interfere with the content of tiddlers while typing. I am not sure whether this is a Noteself problem. I will look into this issue further.

Kind Regards

Could you please explain to me how you did that? In general, if you see numbers on the left side of the input text area that means codemirror is active.

If you can test on and the problem happens there then I’m 99% sure that the problem is the codemirror plugin.

I disabled the plugin in the Control Panel in Plugins.

I can confirm, that disabling/enabling the codemirror plugin causes the problem. I will keep the plugin disabled. With the plugin properly disabled, it works for me on online and developer versions (firefox on android).

My problem occured, as I use the actual android Noteslf App (from Google Play store). I did not find a way to disable the plugin there. The plugin is disabled in the ControlPanel. (In firefox, when I disable the plugin, I have to releoad the page to have it properly disabled). However, in the Noteself android app, I cannot find a way to correctly reload. I tried saving the config to have it reloaded… however, in the App the plugin stays enabled (the line numbers, as well as the problem keep showing up). I guess I will just use firefox without code mirror on my android.

Thank you for your help!

Ok, that makes sense.
I didn’t updated the android app in a while, It’s on my to-do list, I’ll let you know, maybe I will just uninstall the plugin since it is not that useful in mobile anyway.
By the way, the App is not available on the google play store (yet), so you probably downloaded it from it’s github page.