NoteSelf sync service

Hello NoteSelf users…
Today I’m glad to present the beta of our Sync service.
What is this all about ?
Well, many happy users of NoteSelf have complains about how hard is to setup your own database. They like using NoteSelf, but they don’t know how to properly setup a CouchDb server or a Cloudant account. To those users I want to say: leave that to me !
NoteSelf sync service wants to make the synchronization between devices very very easy. You just need an email account under your control and in less than one minute you should be ready to go:

  • No registration
  • No password
  • No configuration
  • No problems (I hope!)

We use a password-less approach, so you don’t need to remember a password and we don’t need to worry about or handle any precious user password (because we all repeat our passwords…) It’s a win-win situation

How does this work, what is the flow ?

  1. Go to the edge version of NoteSelf
  2. Notice the new user icon on the sidebar, click on it and a shiny popup should appear
  3. You provide an email account that you have access to
  4. We generate a random OTP (one time pin) with one hour of validity
  5. We send that pin to your email address
  6. You enter the pin on NoteSelf and we will generate a new database and very long and secure token for you
  7. Everything from here works exactly the same

Please note that the service is on baby steps, and you may find a bug.
Also don’t put very private or very important information on your NoteBooks, but that is something that you should not do on any service so, we’re fine.
It is free and it will be open until we hit the small Cloudant budget I have.
The service is quite simple so the only bug we expect to face is the login server (not the databse) to be down after long periods of inactivity. The database should be fine all time, and once you are logged in you should not face any new problem.
I expect anyone to be responsible and and respectful and not abusing the service, if it goes out of bounds I may be forced to shut it off.

For now this feature is only available on the edge edition, so for trying it you should point your browser to:

Hope you find this new service pleasant to use and that it helps reducing the entry barrier.


Hi Danielo,

Awesome news!

I’d like to report that a JS error popped up when I clicked on the NoteSelf Edge link (Uncaught TypeError: Cannot read property ‘localeCompare’ of null)

I’m on Chrome V67 for Windows10. The JS error happened maybe because I’m already a NoteSelf user on that browser? When I tried again on an Incognito tab I had no trouble creating an account and generating the database.

About the database. Because I don’t want to overload your Bluemix account, is it possible for me to use the one I already have? I tried entering my info on $:/ControlPanel > TiddlyPouch but I got logged out of the system after doing a refresh.

Although I know the usual NoteSelf is already working well, I’d just like to try my db on this new system.

Thanks for your hard work!


Hello @_jd,
Thank you for your error report and your positive feedback. I didn’t tried the new feature with any of my pre-existing databases,so it may be some situation that I don’t think about. I’ll give it a try.

In fact it is the only way :smile: , for now…
As I said,this works exactly the same like any other database,but just with a nicer UI and password experience. Just log in with your email, open the control panel and take note of the generated credentials,they should be there. Then just use those credentials on your already existing database. You may need a page refresh for the switching operation.
I’m writing from my phone and from memory,so you could find something I didn’t think about. In such case just let me know and I’ll try to write down more detailed instructions


I have an issue with this new sync service.
I am able to login with OTP pin on one device, but it stops working as soon as I login on my other device.
$:/state/tiddlypouch/sync/Log has error “forbidden” with reason “_reader accesss is required for this request”.

As I can see in database settings, every new login produces new api key (Remote user-name field), may be the problem is in it.

  1. I tried to manually copy this new api key from second to first device but it does not work.
    And (not sure if it is related) there were popup with sync error of $:/status/UserName (btw, I am unable to change it: after every page reload it get same old value, which corresponds to old api key).

  2. I also tried to setup sync on third device, not using OTP pin - just copying data from working instance. That doesn’t work either.
    $:/state/tiddlypouch/sync/Log is empty in this case.

  3. Also I tried to delete local database (button in ToddlyPouch database settings). I tried all that steps in different combinations, w/o any success.

Can you tell what is happening and how can I setup sync with multiple devices?


Well, I think I’ve found a part of answer: there is also a password, which is not visible in ui, but stored in $:/plugins/danielo515/tiddlypouch/config/selected_database.

It’s weird that NS sync does not show any error warning, even in debug log…

I tried to follow these steps to start a new syncable Notebook…
but I just get an error message (“Network Error”) and PIN was not emailed).

Guess I’m missing something?

This is what I did (from this forum topic, on Chrome browser, on my android 8 phone):

  1. tapped on the link for the “edge version”
  2. tapped on the user logo
  3. wrote my email address
  4. tapped on “get pin” button
  5. got error message

Here is a screenshot:

Hello @jero, Welcome to the community.

Thanks for trying out the sync service.

Can you try the same thing on a desktop chrome ? It is easier to look for problems on desktop browsers. Have you tried just once or maybe twice on a row ? Sometimes the service is “slept” and it takes it a couple of minutes to wake up, so sometimes trying twice fixes the problem.
Thank you very much

Tank you very much for your answer.

I tried (several times) the same steps from 1 to 5 as listed on my last message, but now on Chrome on Windows 10.
Every time I got the same error message.

I wonder whether I am the only one experiencing this?

Or should I have done some previous steps (maybe downloading the .html TidddlyWiki file or something)?

I am also getting the Network Error when requesting a PIN on a Windows desktop Chrome as well as FireFox.

Sorry to hear that @jero and @AdamHouston,
I’ll be trying tonight to see if the same happens to me.


Hello Everyone, @AdamHouston and @jero,
The sync service should be back online again.
But, we are migrating to a more stable and reliable service, so the sync service will not get this kind of problems in the future.


Great, thank you so much, I’ll check it out tomorrow first thing!

When I request a PIN on Windows 10, I get a network error. This happens on all browsers.

Just restarted the service (still working on the new service deployment).
Does it work now?

It works now, thank you!

Tried to setup Cloudant with lots of headaches so happy an very grateful for the quick notesefl edge option. However, I keep getting the following message

syncer-browser - 18:01:02 1 4 2019

Sync error while processing ‘$:/status/UserName’: TypeError: Cannot read property ‘rev’ of undefined

I tried it on my Vivaldi browser (latest version) with Linux Peppermint OS.

Also, I’m trying to setup NoteSelf on my Android phone so I can use my TiddlyWiki on both devices, with automatic sync between them enabled. I’m pretty new at all this and can’t seem to get it up and running. Read all the FAQ’s/forum etc but wonder if there’s a step by step guide available?


@emgee13, the username error is a continuous headache, I’m still trying to figure out how to fix it and still make the user syncing…
If you ignore that error, does the sync work?

How are you setting it up? Can you try to set it up using chrome for android?