Firefox: Online Versions of NoteSelf do not sync with custom CouchDB Server


I was trying to use the online versions (i.e. ) to get my notebook synced.
I have my own CouchDB server running with a valid certficate for the domain for https access.

I am not able to get any of the ‘online’ versions (online, edge, gsd5, dev) for Firefox Desktop on Ubuntu 18.04. to sync with my CouchDB server.
To be clear: It works using chrome on the same desktop. It works using firefox on android. It works using a self hosted “offline” noteself.html 5.1.21.
Only for the desktop Firefox, using any online version, no sync happens.

I do not get any Error. Pushing the “Login” Button (after entering all necessary data) does nothing.
The Console tells me:

PouchAdaptor: About to log in…
PouchAdaptor: Login succeed
Step Login succeeded!!
Step Get status succeeded!!

But there is no sync starting.

Additional question: I want to test the GSD5 version of NoteSelf. As the online versions do not work for me currently (as described). Where can I find the offline html file for the GSD5 NoteSelf Version?

I fixed the issue by unblocking my couchDB Server “Third Party Cookie”.

I already suspected some “security” related settings, as it only occurred on the desktop firefox. As the couchDB server has to maintain a session, it is considered a third party cookie, coming from a different domain. I also had to explicitly enter the correct protocol (‘https’) and port (I missed that point) in the Permission Exceptions of “Cookies and Site Data” in Firefox preferences.

1 Like

Hello @steffenms, glad you figured it out and thank you very much for reporting it back.
I don’t use firefox at all, so I am not able to help here, but yeah, your guess are correct, any couchdb server will set a session cookie, so we (the client) don’t need to send the credentials with every request.


I have the very same issue as steffenms desribes, but cannot apply his solution, since I do not really know how to solve it.

Please give me some more details how I can fix this issue, which has been appearing for some days.

Thx in advance!

Hello @Spooky_Fox, just to confirm that the problem is firefox, can you try some other browser? Chrome or Edge?

Hi, just to clarify my issue and my solution.
If you use one of the online versions, you are making requests to the domain When you put a couchdb server in place, the noteself site makes your browser to request data from that couchdb server on another domain e.g.
Such a behavior is recognized as “third party cookie”, as this is often used to track users through websites (Facebook like button, Google Analytics, etc.). Such requests to domains the user did not call explicitly, can be blocked by a browser setting. In the future, Firefox and chrome plan to block such “third party cookies” by default.
Currently, you probably set that setting by yourself. Search for “third party cookies” for your browser and you will find the settings. Usually you can put exceptions or permissions in place. Enter your couchdb server with full address and port ( as permission. This solves the described problem.

I just learned that Firefox has very much changed its settings towards this, at least on mobile browser. It is now called “enhanced tracking protection”. If I understand the new browser settings correctly from the first glimpse, you can no longer give permission to a target (couchdb) but only the source ( by disabling tracking protection for that site. I find this a bit inconvenient as I did not have to provide tracking permission to (with google analytics plugin running) but have to now.