Can only log in from one browser on android, confused


I’m using Hermit on Android, (chrome-based browser) and it works smoothly.

My problem is that I can’t connect to my cloudant server (which has been working since 2018, if I remember rightly) from anywhere else. I’ve tried this on different days, different devices, different browsers…

I can get to the cloudant dashboard, and I can log in from that one browser, but not from anywhere else.

I’m copy-pasting the CouchDB URL and the remote database name. I’m copy-pasting the password too. The Notebook Name is the default MyNotebook… I can’t think what else is going wrong.

Does anyone have any ideas?

Thanks for reading!

Is a yellow error toast when I tap/click ‘login’ - it reads, ‘PouchAdaptor’ ‘login failed’.

Everywhere except in the one browser - hermit on Android. Maybe there’s a cookie that’s keeping it working there? It used to work everywhere, and I didn’t edit anything in the server settings until long after the problem appeared.

Hello @Tom,
If it works on Hermit, it should work on other browsers. Yes,login is handled through a cookie, so it may be the case that Hermit got it long time ago and you have been just renewing it since then.
Are you trying only on android browsers or are you referring to desktop browsers too? If you can check on desktop, can you provide an screenshot of your debug console on chrome? Specific the network tab

Can you try login to the free NoteSelf sync service with an empty DB/notebook? That method is always guaranteed to set the proper user and password, so if that works we can focus on finding the right credentials for your own server.

Hello @danielo515

I’ve tried from chrome and firefox on desktop and android.

  1. Here’s a screencap of the network tab:

  2. The free NoteSelf sync service works for me. I notice that my CouchDB URL has my password in and my username twice, where the automatic one has just the username once.

The NoteSelf sync service … if I open it in two instances of chrome on my pc and use the same email address for both, is it supposed to sync between them? It seems to be connecting to the same database name with the same username, but making a tiddler in one doesn’t seem to make it in the other. I did try refreshing the page.

Hope that’s helpful, and thank you so much for helping.

Hello @Tom,
That screenshot shows a failed login and then a successful login, which is the normal flow for couchdb.

It should, but I never tested that way. The way I use it is between different devices, so if you try on your computer and your phone (for example) or between chrome and firefox it should work as you describe.

About your specific login problems, can you share with me your console tab (on developer tools) keeping it open while you login? I mean, open the console, try to login and then take an screenshot.


Thank you

I’m so confused. I can’t use my PC right now, so I downloaded the developer version of Chrome on Android, which, it turns out, doesn’t have the same dev tools.
I can log in to noteself in the dev version, though!

So I went back to regular Chrome and tried clearing the cache and logging in using the same URL & password… nothing. Cleared cache again and tried again, nothing.

I’ll get back to you with a console tab screenshot tomorrow.

Yeah, I’m really very confused. It works in the Hermit lite app, and it works in Chrome Dev on android, but nowhere else (tried both windows and android versions of chrome, firefox and brave… also edge on windows, just because it was there… Nothing except Hermit lite and Chrome Dev work…

scrolled up in console window:

On the screenshot it is missing the remote user-name. It is something you forgot to add or you were just trying things?
Also, make sure you have the “old” auth method active on cloudant (if you are using cloudant).

  1. I’ve tried using the couchdb username and I think an ap key in the ‘remote user-name’ box, but in hermit where I still have access, that box is blank.
  2. I searched for about thirty minutes for a setting that talked about authentication methods in cloudant. I know I’ve been using it since the start of 2018, so I hoped it would be on the old authentication method by default…
  3. I notice in hermit I have the old login prompt, and in Chrome Dev I have the new one… I’m not sure why that is, but I can log in in both of those browsers.

So I’ve been continuing to use noteself on my phone without access anywhere else.

I still have access from Chrome Dev on Android and the Hermit lite app, and I still can’t log in anywhere else.

I’m just bumping this in case danielo515 or anyone else has any ideas.

Ok, let’s recap.
Does your connection settings look anything similar to this?

When you try to log in, how does it fail? Does it show you a logging error message? Can you show us an screenshot of chrome devtools? First, open chrome developer tools->network tab, then try to login. and take an screenshot.
Here is a video about how to open chrome dev-tools:

If you have access to your cloudant dashboard, one easy way to generate credentials is on the permissions tab of your database. Take a look at the following screenshots:

1 Like

Having looked at your screenshot, I wonder whether I should use an api key and password rather than … whatever it is I’m using now.
Or maybe what I’m using is an api key and it’s just a different format.

It’ll probably take me twenty minutes to get back into my cloudant dashboard to check, and I should hopefully be able to get the requested dev-tools screenshot to you by Monday.

Thanks for your time again. I really appreciate it.

Ok, sat down in front of my PC and got into cloudant in about two minutes, which I think is a record!

I generated an API key, entered the details, saved the config and pressed login.

This time, instead of throwing an error message, the login popup just stayed there. Nothing seemed to change when I clicked ‘login’.

Devtools show that my credentials are ok, I think… Pretty sure I clicked login twice.

and scrolled up:

The error message I was getting previously (using the admin credentails rather than the api key) was like this:

With a dev console looking like this:

Can I provide anything else that might be useful?

I would guess I’ve connected to the wrong database or notebook, but those details are the same as in the browser that’s logging in normally.

I just tried again in incognito mode on chrome - the login window stays, but if I switch from the ‘Custom’ tab back to the ‘NoteSelf’ tab of the login window it says ’ You are now logged in. Wohhoo!!’ - unfortunately I don’t get any of my tiddlers.

Same, here.
It says I’m logged in but nothing happens on the database side when saving changes.
Not real Wohhoo!!..

I made a new ibm account and went through the setup process again then imported my wiki - success!

I’m not sure what it was, but probably starting a new cloudant instance would do it for you. Maybe even just a new database on cloudant, but I haven’t tested those two theories.

@sa162014 @danielo515